You are on website enabling to check whether your browser has properly configured all options required for correct working of Edumatic system. The Edumatic system works with Internet Explorer and Mozilla Firefox browsers.
  • Your computer:

    The system recognised, that you were using the following browser:
    Screen resolution:

  • Prerequisites for logging into the Edumatic system:

    (If your browser settings are incorrect () look how to change them for proper system work.)

  • Software required for using Internet trainings:


    If above the "Edumatic" and "Adobe Flash Player" inscriptions are not being shown means that you do not have installed correct version of the Adobe Flash Player plugin. Download the latest version of plugin Adobe Flash Player

  • Software which can be required for using some Internet trainings:

    Open documentto check whether you have installed Adobe Acrobat Reader software.
    If you failed to open the above document, download and install Adobe Acrobat Reader software.